バージョン: 1.5.3
オンラインユーザー数: 8
閲覧数表示 本日/トータル: 1 / 1938
最終更新:2014-12-04 (木) 01:18:07
アドバタイズドディスタンス(AD) | ネクストホップルータから宛先NWまでのコスト(メトリック) |
フィージブルディスタンス(FD) | ローカルルータから宛先NWまでのコスト(メトリック) |
サクセサ | ループにならないことが保障された最小コスト(最小FD)を持つネクストホップルータ、実際のパケット転送に利用される |
フィージブルサクセサ(FS) | サクセサのバックアップ用ネクストホップルータを指す、FSになるにはAD(アドバタイズドディスタンス)値が現在のサクセサのFD(フィージブルディスタンス)値より小さい必要がある |
R1(config-if)#ip hello-interval eigrp 1000 2 | Helloインターバルの設定変更AS1000を2秒に変更 |
R1(config-if)#ip hold-time eigrp 1000 6 | ホールドタイムの設定変更AS1000を6秒へ変更(Helloの3倍推奨) |
R1(config-if)#bandwidth 64 | IF帯域幅指定、Etherでは不要Serial等で利用左記は64kbps |
R1(config-if)#ip summary-address eigrp 1000 172.16.16.0 255.255.254.0 | 手動経路集約、no auto-summaryとセットかつ、対抗はauto-summry出なければ効果無し |
R1(config)#router eigrp 1000 | AS1000番でEIGRPプロセス起動 |
R1(config-router)#network 10.20.20.0 0.0.0.255 | EIGRPを動作させるIFを指定 |
R1(config-router)#metric weights 0 0 0 1 0 0 | EIGRPメトリックのK値変更 <TOS><K1-5>の値を変更するToS値は常に0 |
R1(config-router)#neighbor 10.20.20.2 fastEthernet 0.200 | 224.0.0.10マルチキャストを送受信しなくなり、EIGRPパケットをユニキャストでのみ送受信する |
R1(config-router)#maximum-paths 5 | 負荷分散(Def4、1にすると無効) |
R1(config-router)#variance 2 | 不等コストロードバランス(Def1で無効)<multiplier>に2を入力するとサクセサのFD(メトリック)の2倍より小さいメトリックのルートを利用して不等コスト負荷分散をする |
R1(config-router)#passive-interface ethernet 0 | Eth0に流れるEIGRP Helloパケットを止めます |
R1(config-router)#no auto-summary | 自動経路集約の無効化(Def有効) |
※neighborでマルチキャストを止めると当然両方設定をあわせないとEIGRP交換は落ちる
*Mar 1 05:36:01.567: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1000: Neighbor 10.20.20.2 (FastEthernet0.200) is down: Static peer configured
K1 | 帯域幅 | 初期値(1) |
K2 | 負荷 | 初期値(0) |
K3 | 遅延 | 初期値(1) |
K4 | 信頼性 | 初期値(0) |
K5 | MTU | 初期値(0) |
メトリック=(K1x帯域幅) + [(K2x帯域幅)/(256-負荷)] + (K3x遅延)
メトリック=K1x帯域幅 + [(K2帯域幅)/(256-負荷)] + (K3x遅延) x (K5/(信頼性+K4))
不等コストロードバランシングの対象は、次の2つの基準を満たしている必要がある。
・フィージブルサクセサのルート
・『サクセサのFD(メトリック) x <multiplier>』の値より小さいFDを持つルート
デフォルトルート候補のクラスフルネットワークを受信した個々のEIGRPルータは、そのルートをデフォルトゲートウェイのように扱います。
R1(config)#ip route 192.168.100.0 255.255.255.0 10.10.10.1 | スタティックルート指定(クラスフル) |
R1(config)#router eigrp 1000 | EIGRPプロセス1000へ |
R1(config-router)#network 10.20.20.0 0.0.0.255 | ネットワーク指定 |
R1(config-router)#redistribute static | スタティック再広報 |
R1(config-router)#exit | ルータモードを抜ける |
R1(config)#ip default-network 192.168.100.0 | クラスフルでデフォルトルートの再広報 |
R1(config)#do show ip route Gateway of last resort is 10.10.10.1 to network 192.168.100.0 10.0.0.0/24 is subnetted, 7 subnets D 10.41.41.0 [90/30720] via 10.40.40.2, 00:48:41, FastEthernet0.400 C 10.40.40.0 is directly connected, FastEthernet0.400 D 10.31.31.0 [90/30720] via 10.30.30.2, 00:48:41, FastEthernet0.300 C 10.30.30.0 is directly connected, FastEthernet0.300 D 10.21.21.0 [90/33280] via 10.40.40.2, 00:48:42, FastEthernet0.400 [90/33280] via 10.30.30.2, 00:48:42, FastEthernet0.300 C 10.20.20.0 is directly connected, FastEthernet0.200 C 10.10.10.0 is directly connected, Ethernet0 S* 192.168.100.0/24 [1/0] via 10.10.10.1
R2#show ip route Gateway of last resort is 10.20.20.1 to network 192.168.100.0 10.0.0.0/24 is subnetted, 6 subnets D 10.41.41.0 [90/33280] via 10.20.20.1, 00:50:03, FastEthernet0 D 10.40.40.0 [90/30720] via 10.20.20.1, 00:50:04, FastEthernet0 D 10.31.31.0 [90/33280] via 10.20.20.1, 00:50:03, FastEthernet0 D 10.30.30.0 [90/30720] via 10.20.20.1, 00:50:04, FastEthernet0 C 10.21.21.0 is directly connected, Ethernet0 C 10.20.20.0 is directly connected, FastEthernet0 D*EX 192.168.100.0/24 [170/40028160] via 10.20.20.1, 00:01:24, FastEthernet0
R1(config)#ip route 0.0.0.0 0.0.0.0 10.10.10.1 | デフォルトルート作成 |
R1(config)#router eigrp 1000 | EIGRPプロセス1000へ |
R1(config-router)#redistribute static | スタティック/デフォルトルート再広報 |
又は
R1(config)#ip route 0.0.0.0 0.0.0.0 10.10.10.1 | デフォルトルート作成 |
R1(config)#router eigrp 1000 | EIGRPプロセス1000へ |
R1(config-router)#network 0.0.0.0 | デフォルトルート再広報 |
フレームリレーはNBMA(Non-Broadcast Multiple Access)と呼ばれ、マルチキャスト/ブロードキャストを
していないマルチアクセスネットワークの事です。
EIGRPはブロードキャストを必要とするため、擬似ブロードキャストを実装しています
ダイナミックマッピング | Inverse ARPによって動的に構成 |
スタティックマッピング | frame-relay mapコマンドにより管理者が静的に構成 |
ハブアンドスポーク(スター)トポロジ | 中心となる拠点(ハブ)からその他の拠点(スポーク)にPVCを確立 |
フルメッシュトポロジ | 全ての拠点でPVCを確立して相互に接続します |
パーシャル(部分)メッシュトポロジ | 重要拠点を相互接続し、残りをハブアンドスポークで接続します |
R2(config)#interface serial 0 R2(config-if)#ip address 10.255.255.254 255.255.255.0 R2(config-if)#encapsulation frame-relay R2(config-if)#no ip split-horizon eigrp 1000※EIGRPスプリットホライズンを無効化
R2(config)#interface serial 0 R2(config-if)#ip address 10.255.255.254 255.255.255.0 R2(config-if)#encapsulation frame-relay R2(config-if)#no ip split-horizon eigrp 1000 R2(config-if)#frame-relay map ip 10.255.255.253 111 broadcast R2(config-if)#no frame-relay inverse-arp※EIGRPスプリットホライズンを無効化
EIGRPスプリットホライズン | EIGRPはディスタンスベクタである為、NBMA環境ではスプリットホライズンによってルート情報が伝播されない可能性があります。 |
Inverse ARP | 対向ルータのL3アドレス(IPアドレス)とPVCの入り口を区別するL2アドレス(DLCI)を動的マッピングし、フレームリレーを構成する。 |
Bandwidthコマンドで指定された数値を100%としてパーセンテージで指定します。
R2(config-if)#ip bandwidth-percent eigrp 1000 50
EIGRP認証に必要な設定は下記。
① | キーチェーン作成 | R1(config)#key chain TEST-KEY1 |
② | キーIDの作成 | R1(config-keychain)#key 2013 |
③ | キーストリング(パスワード)の設定 | R1(config-keychain-key)#key-string BAKANA |
④ | 受信ライフタイムの設定 | R1(config-keychain-key)#accept-lifetime 7:00:00 1 Jun 2013 18:00:00 Dec 31 2013 |
⑤ | EIGRPのMD5認証の有効化 | R1(config-subif)#ip authentication mode eigrp 1000 md5 |
⑥ | キーチェーンの適用 | R1(config-subif)#ip authentication key-chain eigrp 1000 TEST-KEY1 |
※④は開始時間日月年、終了時間日月年の順で記載
※上記は受信で送信ライフタイムの設定は右記、R1(config-keychain-key)#send-lifetime 7:00:00 Jun 1 2013 infinite(無限)
Key-chain TEST-KEY1: key 2013 -- text "BAKANA" accept lifetime (07:00:00 UTC Jun 1 2013) - (18:00:00 UTC Dec 31 2013) [valid now] send lifetime (07:00:00 UTC Jun 1 2013) - (infinite) [valid now]
EGIRPスタブとして設定されたルータはネイバーへ送信するルートを制限する事が出来る。
デフォルトでは直接接続されたルート(connected)及び集約ルート(summary)のみネイバーへアドバタイズします。
R1(config-router)#eigrp stub [オプション]
R4#show ip eigrp neighbors IP-EIGRP neighbors for process 1000 H Address Interface Hold Uptime SRTT RTO Q Seq (sec) (ms) Cnt Num 1 10.41.41.1 Fa0/1 12 00:00:34 8 200 0 24 0 10.40.40.1 Fa0/0 11 00:00:59 1022 5000 0 41 R4#show ip eigrp neighbors di R4#show ip eigrp neighbors dialer % Incomplete command.
R4#show ip eigrp neighbors detail IP-EIGRP neighbors for process 1000 H Address Interface Hold Uptime SRTT RTO Q Seq (sec) (ms) Cnt Num 1 10.41.41.1 Fa0/1 13 00:00:43 8 200 0 24 Version 12.4/1.2, Retrans: 1, Retries: 0, Prefixes: 3 0 10.40.40.1 Fa0/0 11 00:01:08 1022 5000 0 41 Version 12.4/1.2, Retrans: 0, Retries: 0, Prefixes: 2
R4#show ip route Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS inter area, * - candidate default, U - per-user static route o - ODR, P - periodic downloaded static route Gateway of last resort is not set 10.0.0.0/24 is subnetted, 6 subnets C 10.41.41.0 is directly connected, FastEthernet0/1 C 10.40.40.0 is directly connected, FastEthernet0/0 D 10.31.31.0 [90/30720] via 10.41.41.1, 00:02:14, FastEthernet0/1 D 10.30.30.0 [90/30720] via 10.40.40.1, 00:02:39, FastEthernet0/0 D 10.21.21.0 [90/30720] via 10.41.41.1, 00:02:14, FastEthernet0/1 D 10.20.20.0 [90/30720] via 10.40.40.1, 00:02:14, FastEthernet0/0
R1#show protocols Global values: Internet Protocol routing is enabled Ethernet0 is administratively down, line protocol is down FastEthernet0 is up, line protocol is up FastEthernet0.200 is up, line protocol is up Internet address is 10.20.20.1/24 FastEthernet0.300 is up, line protocol is up Internet address is 10.30.30.1/24 FastEthernet0.400 is up, line protocol is up Internet address is 10.40.40.1/24 R1#
R1#show ip eigrp interfaces IP-EIGRP interfaces for process 1000 Xmit Queue Mean Pacing Time Multicast Pending Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes Fa0.200 1 0/0 108 0/1 676 0 Fa0.300 1 0/0 1 0/1 50 0 Fa0.400 1 0/0 6 0/1 50 0 R1#
R1#show ip eigrp topology IP-EIGRP Topology Table for AS(1000)/ID(10.40.40.1) Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, r - reply Status, s - sia Status
P 10.41.41.0/24, 1 successors, FD is 30720 via 10.40.40.2 (30720/28160), FastEthernet0.400 P 10.21.21.0/24, 2 successors, FD is 33280 via 10.30.30.2 (33280/30720), FastEthernet0.300 via 10.40.40.2 (33280/30720), FastEthernet0.400 P 10.31.31.0/24, 1 successors, FD is 30720 via 10.30.30.2 (30720/28160), FastEthernet0.300 P 10.40.40.0/24, 1 successors, FD is 28160 via Connected, FastEthernet0.400 P 10.30.30.0/24, 1 successors, FD is 28160 via Connected, FastEthernet0.300 P 10.20.20.0/24, 1 successors, FD is 28160 via Connected, FastEthernet0.200 R1#
R1#show ip eigrp topology all-links IP-EIGRP Topology Table for AS(1000)/ID(10.40.40.1) Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, r - reply Status, s - sia Status P 10.41.41.0/24, 1 successors, FD is 30720, serno 29 via 10.40.40.2 (30720/28160), FastEthernet0.400 via 10.30.30.2 (33280/30720), FastEthernet0.300 P 10.21.21.0/24, 2 successors, FD is 33280, serno 35 via 10.30.30.2 (33280/30720), FastEthernet0.300 via 10.40.40.2 (33280/30720), FastEthernet0.400 via 10.20.20.2 (284160/281600), FastEthernet0.200 P 10.31.31.0/24, 1 successors, FD is 30720, serno 34 via 10.30.30.2 (30720/28160), FastEthernet0.300 via 10.40.40.2 (33280/30720), FastEthernet0.400 P 10.40.40.0/24, 1 successors, FD is 28160, serno 9 via Connected, FastEthernet0.400 P 10.30.30.0/24, 1 successors, FD is 28160, serno 8 via Connected, FastEthernet0.300 P 10.20.20.0/24, 1 successors, FD is 28160, serno 7 via Connected, FastEthernet0.200 R1#
R1(config)#do show ip int bri Interface IP-Address OK? Method Status Protocol Ethernet0 unassigned YES unset administratively down down FastEthernet0 unassigned YES manual up up FastEthernet0.200 10.20.20.1 YES manual up up FastEthernet0.300 10.30.30.1 YES manual up up FastEthernet0.400 10.40.40.1 YES manual up up R1(config)#